Selasa, 08 Maret 2011

PPTP dan eoip tunnelling di mikrotik

Untuk membuat VPN dengan PPtP di Mikrotik memang sangat mudah dan bisa lebih mudah daripada di Linux. Yang perlu diperhatikan adalah dengan memastikan mikrotik sudah terinstall paket pptpnya. Sebagai gambaran dalam membangun VPN adalah setiap jaringan lokal klien yang akan terhubung dengan jaringan lokal lainya adalah melalui router gateway. Atau diagramnya menjadi seperti berikut :



LAN (pusat)----router(pusat) <================> router (klien) -- LAN(klien)
10.10.10.0/24 10.10.10.1/24 11.11.11.212/24 11.11.11.0/24
| |
(publik) (publik) 
(201.11.209.12/25) (202.16.11.23/27)
| |
(gw) (gw) 
(201.11.209.1)
| |
11.11.11.1/24---------bridge over eoip-------------| 


Dari skema tersebut semua gateway ke aplikasi di pusat terdapat di ip address list router pusat. Jadi klien benar-benar seolah-olah satu jaringan dengan pusat dan dari LAN klien satu dapat saling berkomunikasi juga . Dengan memanfaatkan eoip untuk tunneling bridge nya.
Untuk lebih lanjut mengenai konfigurasinya sebagai berikut :

*Konfigurasi di Server

- Setting perangkat jaringan (asumsi ether2=lokal, ether1=publik)

-ip address publik
ip address add address=201.11.209.12/25 interface=ether1


-gateway 
/ip route add gateway=201.11.209.1


-ip address lokal
ip address add address=10.10.10.1/24 interface=ether2


- Setting VPN server

1. Buat PPtP server

/interface pptp-server add name=serverpptp disabled=no


2. Buat PPP secret untuk autentifikasi antar router (pusat) dan router (klien)

/ppp secret add name=klien1 password=qwe123 service=pptp local-address=20.20.20.1 remote-address=20.20.20.2


Perintah diatas untuk membuat sebuah user dan password terhadap sebuah klien yang bernama klien1 dan password=qwe123. Service yang digunakan adalah pptp. Ip address 20.20.20.1 dan 20.20.20.2 adalah sebagai point-to-point saja antar klien dan pusat.

3. Buat eoip 

/interface eoip add name=eoip-klien1 remote-address=20.20.20.2 tunnel-id=2


Eoip dibuat dengan nama eoip-klien1 denggan remote address menyesuaikan dari remote address di ppp secret. Untuk tunnel id bebas menggunakan nomor berapa saja, namun jangan sampai terjadi kesamaan tunnel id antara eoip untuk satu klien dan eoip untuk klien yang lainya.

4. Tambah ip address baru dengan melalui interface eoip

/ip address add address=11.11.11.1/24 interface=eoip-klien1


Ip addres diatas adalah ip address yang akan digunakan oleh LAN klien sebagai gateway untuk terhubung dengan pusat.

* Konfigurasi di Router klien

- Setting perangkat jaringan (asumsi ether2=lokal, ether1=publik)

-ip address publik
ip address add address=202.16.11.23/27 interface=ether1


-gateway 
/ip route add gateway=202.16.11.1


-ip address lokal
ip address add address=11.11.11.1/24 interface=ether2


- Setting VPN klien

1. Buat koneksi PPtP klien

/interface pptp-client add name=konek-pptp user=klien1 password=qwe123 disabled=no connect-to=201.11.209.12


2. Buat eoip 

/interface eoip add name=eoip-ke-pusat tunnel-id=2 remote-address=20.20.20.1


3. Buat bridging antara interface ether2 dan eoip yang telah dibuat.

/interface bridge add name=bridge-pusat disabled=no


Tambahkan port dalam bridging

/interface bridge port add interface=ether2 bridge=bridge-pusat


add interface=eoip-ke-pusat bridge=bridge-pusat


Dalam bridge tersebut dibuat 2 port yang menghubungkan interface eoip-pusat dan ether2

Disini semua konfigurasi sudah dilakukan dan tinggal coba test ping dari jaringan klien ke gateway.




sumber : mybaity

Tidak ada komentar:

Poskan Komentar